Τετάρτη, 29 Μαΐου 2013

ΑΕΠΠ : Θέματα και Λύσεις Πανελλαδικών Εξετάσεων 2013

Σήμερα 29/05/2013 οι μαθητές της Τεχνολογικής Κατεύθυνσης εξετάστηκαν στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον.


Τα θέματα μπορείτε να τα κατεβάσετε από το Υπουργείο Παιδείας ενώ ενδεικτικές λύσεις μπορείτε να δείτε στη συνέχεια:




9 σχόλια:

  1. Στο Θέμα Γ Ερωτημα Γ4 στην πρώτη ταξινόμηση πρέπει παράλληλα εκτός από τη στήλη 1 του πίνακα ΜΟ και τον πίνακα ΚΩΔ να ταξινομηθεί και η στήλη 2 του πίνακα ΜΟ. Αν αυτό δε γίνει κατά τη δεύτερη ταξινόμηση δεν έχω σωστή αντιστοιχία τιμών και κωδικών

    ΑπάντησηΔιαγραφή
  2. Έχεις δίκιο σε αυτό που λες. Μόλις το διόρθωσα.

    ΑπάντησηΔιαγραφή
  3. Το Α4 δεν μπορεί να γραφεί και έτσι;

    Για i από 1 µέχρι 100
    Για j από i + 1 µέχρι 100
    ∆ιάβασε Π[i, j]
    Τέλος_επανάληψης
    Τέλος_επανάληψης

    ΑπάντησηΔιαγραφή
    Απαντήσεις
    1. Ναι ειναι σωστο και ετσι.

      Διαγραφή
    2. οχι δεν ειναι σωστο ....
      Για i απο 1 μεχρι 99
      οχι μεχρι 100.....

      Διαγραφή
    3. Έστω η περίπτωση που το i γίνει 100. Τότε η εσωτερική επανάληψη θα είναι

      ΓΙΑ j ΑΠΟ 101 ΜΕΧΡΙ 100

      που είναι ένας βρόχος που απλά δεν θα εκτελεστεί.


      Συνεπώς μπορούμε να πούμε ότι είναι περιττό το 100, δεν είναι όμως και λάθος.

      Διαγραφή
  4. Αυτό το σχόλιο αφαιρέθηκε από τον συντάκτη.

    ΑπάντησηΔιαγραφή
    Απαντήσεις
    1. Πολύ ωραία γραμμένα και ευανάγνωστα! Μια "παρατηρηση".
      Στο 4ο θέμα, στο τμημα δηλώσεων, έχει δηλωθεί η μεταβλητή j
      η οποια τελικά δεν χρησιμοποιείται, μπηκε καταλαθως!
      Επισης, στο ερώτημα Δ5, η τελευταία εντολή πρεπει να ΄ναι η :
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
      (χωρις το ονομα της διαδικασιας)

      Διαγραφή
    2. Δώρα,

      Έχεις δίκιο και για τις 2 περιπτώσεις.

      Διαγραφή