Μετάβαση στο κύριο περιεχόμενο

Πληροφορική Γ' Λυκείου: Επαναληπτική Άσκηση #2 (2021)

Η άσκηση "Κυνήγι σολομού" είναι η δεύτερη άσκηση της σειράς "10 επαναληπτικές ασκήσεις για το μάθημα της Πληροφορικής". Δεν έχει μεγάλο βαθμό δυσκολίας αλλά απαιτείται, για την επίλυση της, η σωστή διαχείριση εμφωλευμένων δομών επανάληψης.

 

2η Επαναληπτική άσκηση στην Πληροφορική (2021)

2η Επαναληπτική Άσκηση

Τίτλος: Κυνήγι σολομού
Κατηγορία: Δομή Επανάληψης

Ο σολομός είναι ένα μεγάλο ψάρι που ζει στα ψυχρά νερά του Ατλαντικού και Ειρηνικού ωκεανού. Περνά το μεγαλύτερο μέρος της ζωής του στη θάλασσα. Όταν όμως έρθει η εποχή που θα γεννήσει, μεταναστεύει συνήθως στις πηγές των ποταμών που είχε γεννηθεί. Κατά τη διάρκεια αυτής της μετανάστευσης οι σολομοί συναντάνε πολλά εμπόδια μεταξύ των οποίων είναι και οι αρκούδες γκρίζλι. Οι αρκούδες μαζεύονται σε καταρράκτες και περιμένουν τους σολομούς να πηδήξουν έξω από το νερό για να τους πιάσουν. Κάποιες προσπάθειες τους είναι επιτυχημένες αλλά υπάρχουν και πολλές αποτυχημένες προσπάθειες. Έστω λοιπόν ότι σε ένα καταρράκτη ενός ποταμού έχουν μαζευτεί δεκαπέντε αρκούδες. 

Να γραφεί πρόγραμμα το οποίο: 

α) Για κάθε αρκούδα, θα διαβάζει το αποτέλεσμα κάθε προσπάθεια της («Ε» αν η προσπάθεια ήταν επιτυχημένη, «Α» αν η προσπάθεια ήταν αποτυχημένη και «Τ» αν πήγε να ξεκουραστεί), 

β) Θα εμφανίζει πόσες, κατά μέσο όρο, προσπάθειες απαιτούνται για να πιάσει μία αρκούδα ένα σολομό και 

γ) Θα εμφανίζει πόσοι σολομοί κατάφεραν να γλυτώσουν και να συνεχίσουν το ταξίδι τους στο ποτάμι. 

 

Λύση 2ης επαναληπτικής άσκησης

ΠΡΟΓΡΑΜΜΑ Κυνήγι_Σολομού
ΜΕΤΑΒΛΗΤΕΣ 
  ΑΚΕΡΑΙΕΣ: Ι, Σ_ΠΡΟΣΠ, Ε_ΠΡΟΣΠ, ΓΛΥΤΩΣΑΝ, ΠΡΟΣΠΑΘΕΙΕΣ, ΕΠΙΤΥΧΙΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΠΡΟΣΠ
ΑΡΧΗ 

  ΓΛΥΤΩΣΑΝ <- 0
  ΠΡΟΣΠΑΘΕΙΕΣ <- 0
  ΕΠΙΤΥΧΙΕΣ <- 0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 15

    ΓΡΑΨΕ 'Αρκούδα: ', Ι

    Σ_ΠΡΟΣΠ <- 0
    Ε_ΠΡΟΣΠ <- 0
    ΓΡΑΨΕ 'Ποιο ήταν το αποτέλεσμα της προσπάθειας της; '
    ΔΙΑΒΑΣΕ ΠΡΟΣΠ

    ΟΣΟ ΠΡΟΣΠ <> 'Τ' ΕΠΑΝΑΛΑΒΕ

      Σ_ΠΡΟΣΠ <- Σ_ΠΡΟΣΠ + 1
      ΑΝ ΠΡΟΣΠ = 'Ε' ΤΟΤΕ
        Ε_ΠΡΟΣΠ <- Ε_ΠΡΟΣΠ + 1
      ΤΕΛΟΣ_ΑΝ

      ΓΡΑΨΕ 'Ποιο ήταν το αποτέλεσμα της προσπάθειας της; '
      ΔΙΑΒΑΣΕ ΠΡΟΣΠ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΓΛΥΤΩΣΑΝ <- ΓΛΥΤΩΣΑΝ + Σ_ΠΡΟΣΠ - Ε_ΠΡΟΣΠ
    ΠΡΟΣΠΑΘΕΙΕΣ <- ΠΡΟΣΠΑΘΕΙΕΣ + Σ_ΠΡΟΣΠ
    ΕΠΙΤΥΧΙΕΣ <- ΕΠΙΤΥΧΙΕΣ + Ε_ΠΡΟΣΠ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Κατά μέσο όρο απαιτούνται ', ΠΡΟΣΠΑΘΕΙΕΣ/ ΕΠΙΤΥΧΙΕΣ, ' προσπάθειες.'
  ΓΡΑΨΕ 'Γλύτωσαν ', ΓΛΥΤΩΣΑΝ, ' σολομοί. '

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Κυνήγι_Σολομού

 

Άλλες επαναληπτικές ασκήσεις

Οι υπόλοιπες επαναληπτικές ασκήσεις της σειράς υπάρχουν στο άρθρο:

10 Επαναληπτικές Ασκήσεις στην Πληροφορική (2021) 


Παρόμοιες επαναληπτικές ασκήσεις υπάρχουν στο άρθρο:

30 Επαναληπτικές Ασκήσεις για το μάθημα της Πληροφορικής

 

Σχόλια

Δημοφιλείς αναρτήσεις από αυτό το ιστολόγιο

10 Επαναληπτικές Ασκήσεις στην Πληροφορική (2021)

Πληροφορική Γ' Λυκείου: Θέματα Προσομοίωσης 2021

Πληροφορική Γ' Λυκείου: Θέματα Προσομοίωσης 2020