Μετάβαση στο κύριο περιεχόμενο

Πληροφορική Γ' Λυκείου: Επαναληπτική Άσκηση #3 (2021)

Η τρίτη επαναληπτική άσκηση της σειράς "10 επαναληπτικές ασκήσεις για το μάθημα της Πληροφορικής" έχει τίτλο "Τετραγωνική ρίζα αριθμού" και σχετίζεται με την εφαρμογή του αλγορίθμου της δυαδικής αναζήτησης για την εύρεση του ακέραιου μέρους της τετραγωνικής ρίζας ενός αριθμού.

 

3η Επαναληπτική άσκηση στην Πληροφορική (2021)

 

3η Επαναληπτική Άσκηση

Τίτλος: Τετραγωνική ρίζα αριθμού
Κατηγορία: Δυαδική αναζήτηση

Για την εύρεση του ακεραίου μέρους της τετραγωνικής ρίζας ενός θετικού ακέραιου αριθμού Ν μπορούμε να χρησιμοποιήσουμε τις ενσωματωμένες συναρτήσεις μίας γλώσσας προγραμματισμού. Μία εναλλακτική μέθοδος υπολογισμού του ακεραίου μέρους της τετραγωνικής ρίζας ενός αριθμού είναι με εφαρμογή του αλγορίθμου της δυαδικής αναζήτησης στο διάστημα [1, Ν]. Ο αλγόριθμος έχει ως εξής: Αρχικά βρίσκουμε το μεσαίο στοιχείο του διαστήματος και ελέγχουμε το τετράγωνο του μεσαίου αυτού στοιχείου σε σχέση με τον αριθμό Ν. Αν είναι ίσο βρήκαμε την τετραγωνική ρίζα του αριθμού και σταματάμε. Αλλιώς αν είναι μεγαλύτερο συνεχίζουμε την αναζήτηση στο τμήμα που βρίσκεται αριστερά του μεσαίου στοιχείου. Τέλος αν είναι μικρότερο συνεχίζουμε την αναζήτηση στο τμήμα που είναι δεξιά του μεσαίου στοιχείου και ταυτόχρονα θεωρούμε ότι ο ζητούμενος αριθμός είναι ο μεσαίος αυτός αριθμός. Για παράδειγμα έχουμε: 

         Είσοδος          Έξοδος 

             9                      3

            20                     4

            24                     4 

Να γραφεί πρόγραμμα το οποίο: 

α) Θα διαβάζει έναν θετικό ακέραιο αριθμό και 

β) Θα υπολογίζει, με χρήση του αλγορίθμου δυαδικής αναζήτησης, το ακέραιο μέρος της τετραγωνικής ρίζας του αριθμού αυτού.

 

Λύση 3ης επαναληπτικής άσκησης

ΠΡΟΓΡΑΜΜΑ Τετραγωνική_Ρίζα
ΜΕΤΑΒΛΗΤΕΣ 
  ΑΚΕΡΑΙΕΣ: ΑΡ, ΑΡΧ, ΤΕΛΟΣ, ΜΕΣΑΙΟ, ΤΕΤΡ
  ΛΟΓΙΚΕΣ: ΒΡΕΘΗΚΕ
ΑΡΧΗ 

  ΓΡΑΨΕ 'Δώσε έναν θετικό ακέραιο αριθμό: '
  ΔΙΑΒΑΣΕ ΑΡ

  ΑΡΧ <- 1
  ΤΕΛΟΣ <- ΑΡ
  ΒΡΕΘΗΚΕ <- ΨΕΥΔΗΣ

  ΟΣΟ ΑΡΧ <= ΤΕΛΟΣ ΚΑΙ ΟΧΙ ΒΡΕΘΗΚΕ ΕΠΑΝΑΛΑΒΕ
    ΜΕΣΑΙΟ <- ( ΑΡΧ + ΤΕΛΟΣ) div 2

    ΑΝ ΜΕΣΑΙΟ^ 2 = ΑΡ ΤΟΤΕ
      ΒΡΕΘΗΚΕ <- ΑΛΗΘΗΣ
      ΤΕΤΡ <- ΜΕΣΑΙΟ
    ΑΛΛΙΩΣ_ΑΝ ΜΕΣΑΙΟ^ 2 > ΑΡ ΤΟΤΕ
      ΤΕΛΟΣ <- ΜΕΣΑΙΟ - 1
    ΑΛΛΙΩΣ
      ΑΡΧ <- ΜΕΣΑΙΟ + 1
      ΤΕΤΡ <- ΜΕΣΑΙΟ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ 'Το ακέραιο μέρος της τετραγωνικής ρίζας του αριθμού ', ΑΡ, ' είναι: ', ΤΕΤΡ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Τετραγωνική_Ρίζα

 

Άλλες επαναληπτικές ασκήσεις

Οι υπόλοιπες επαναληπτικές ασκήσεις της σειράς υπάρχουν στο άρθρο:

10 Επαναληπτικές Ασκήσεις στην Πληροφορική (2021) 


Παρόμοιες επαναληπτικές ασκήσεις υπάρχουν στο άρθρο:

30 Επαναληπτικές Ασκήσεις για το μάθημα της Πληροφορικής

 

Σχόλια

Δημοφιλείς αναρτήσεις από αυτό το ιστολόγιο

10 Επαναληπτικές Ασκήσεις στην Πληροφορική (2021)

Πληροφορική Γ' Λυκείου: Θέματα Προσομοίωσης 2021

Πληροφορική Γ' Λυκείου: Θέματα Προσομοίωσης 2020