Μετάβαση στο κύριο περιεχόμενο

Πληροφορική Γ' Λυκείου: Επαναληπτική Άσκηση #4 (2021)

Η τέταρτη επαναληπτική άσκηση της σειράς "10 επαναληπτικές ασκήσεις για το μάθημα της Πληροφορικής" έχει τίτλο "Ταξινόμηση σε δόσεις" και σχετίζεται με την εφαρμογή του αλγορίθμου της ταξινόμησης φυσαλίδας σε ένα μόνο μέρος ενός μονοδιάστατου πίνακα.

 

4η Επαναληπτική άσκηση στην Πληροφορική (2021)
 

4η Επαναληπτική Άσκηση

Τίτλος: Ταξινόμηση σε δόσεις
Κατηγορία: Ταξινόμηση

Ο Σωκράτης επιθυμούσε να ταξινομήσει τριάντα αριθμούς σε αύξουσα σειρά. Η διαδικασία φαινόταν απλή αλλά ο Σωκράτης ήξερε μόνο να ταξινομεί είκοσι αριθμούς. Σκέφτηκε λοιπόν να κάνει το εξής: να ταξινομήσει τους πρώτους είκοσι αριθμούς, στη συνέχεια τους είκοσι τελευταίους και τέλος ξανά τους είκοσι πρώτους. 
 
Να γραφεί πρόγραμμα το οποίο: 
α) Θα διαβάζει τα στοιχεία ενός μονοδιάστατου πίνακα τριάντα ακεραίων αριθμών, 
β) Θα υλοποιεί διαδικασία η οποία θα δέχεται ως είσοδο έναν μονοδιάστατο πίνακα και δύο ακεραίους αριθμούς Ν και Μ και θα ταξινομεί όλα τα στοιχεία του πίνακα που βρίσκονται μεταξύ των θέσεων Ν και Μ (των θέσεων συμπεριλαμβανομένων) κατά αύξουσα σειρά, 
γ) Θα καλεί τη διαδικασία ταξινόμησης τρεις φορές: μία για να ταξινομήσει τα πρώτα είκοσι στοιχεία του πίνακα, μία για να ταξινομήσει τα είκοσι τελευταία στοιχεία του πίνακα και μία για να ταξινομήσει ξανά τα είκοσι πρώτα στοιχεία του πίνακα και 
δ) Θα επιβεβαιώνει ότι με την εφαρμογή της παραπάνω μεθόδου ο πίνακας ταξινομείται κατά αύξουσα σειρά.

 

Λύση 4ης επαναληπτικής άσκησης

ΠΡΟΓΡΑΜΜΑ Ταξινόμηση_σε_Δόσεις
ΜΕΤΑΒΛΗΤΕΣ 
  ΑΚΕΡΑΙΕΣ: Ι, ΠΙΝ[30] 
  ΛΟΓΙΚΕΣ: ΤΑΞΙΝΟΜ
ΑΡΧΗ 

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
    ΓΡΑΨΕ 'Ποιος είναι ο ', Ι, 'ος αριθμός: '
    ΔΙΑΒΑΣΕ ΠΙΝ[Ι] 
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(ΠΙΝ, 1, 20) 
  ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(ΠΙΝ, 11, 30) 
  ΚΑΛΕΣΕ ΤΑΞΙΝΟΜΗΣΗ(ΠΙΝ, 1, 20) 

  ΤΑΞΙΝΟΜ <- ΑΛΗΘΗΣ
  Ι <- 2
  ΟΣΟ Ι <= 30 ΚΑΙ ΤΑΞΙΝΟΜ ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΠΙΝ[Ι] > ΠΙΝ[Ι - 1] ΤΟΤΕ
      ΤΑΞΙΝΟΜ <- ΨΕΥΔΗΣ
    ΤΕΛΟΣ_ΑΝ
    Ι <- Ι + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΡΑΨΕ ''
  ΑΝ ΤΑΞΙΝΟΜ ΤΟΤΕ
    ΓΡΑΨΕ 'Μπράβο!! Κατάφερες να ταξινομήσεις τον πίνακα.'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Δυστυχώς δεν κατάφερες να ταξινομήσεις τον πίνακα.'
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ Ταξινόμηση_σε_Δόσεις

ΔΙΑΔΙΚΑΣΙΑ ΤΑΞΙΝΟΜΗΣΗ(ΠΙΝ, Ν, Μ) 
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Ξ, Ν, Μ, ΠΙΝ[30], ΤΕΜΠ
ΑΡΧΗ

  ΓΙΑ Ι ΑΠΟ Ν + 1 ΜΕΧΡΙ Μ
    ΓΙΑ Ξ ΑΠΟ Μ ΜΕΧΡΙ Ι ΜΕ_ΒΗΜΑ -1
      ΑΝ ΠΙΝ[Ξ] > ΠΙΝ[Ξ - 1] ΤΟΤΕ
        ΤΕΜΠ <- ΠΙΝ[Ξ] 
        ΠΙΝ[Ξ] <- ΠΙΝ[Ξ - 1] 
        ΠΙΝ[Ξ - 1] <- ΤΕΜΠ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Άλλες επαναληπτικές ασκήσεις

Οι υπόλοιπες επαναληπτικές ασκήσεις της σειράς υπάρχουν στο άρθρο:

10 Επαναληπτικές Ασκήσεις στην Πληροφορική (2021) 


Παρόμοιες επαναληπτικές ασκήσεις υπάρχουν στο άρθρο:

30 Επαναληπτικές Ασκήσεις για το μάθημα της Πληροφορικής

Σχόλια

Δημοφιλείς αναρτήσεις από αυτό το ιστολόγιο

10 Επαναληπτικές Ασκήσεις στην Πληροφορική (2021)

Πληροφορική Γ' Λυκείου: Θέματα Προσομοίωσης 2021

Πληροφορική Γ' Λυκείου: Θέματα Προσομοίωσης 2020